Uploaded image for project: 'CloverDX'
  1. CloverDX
  2. CLO-6741

Potentially wrong java.home used in server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: rel-4-1-1
    • Component/s: Server
    • Security Level: Users (General product issues)
    • Labels:

      Description

      When I run the tomcat bundle from http://linda/jenkins/view/4.1.x/view/Trunk-4.1/job/cloveretl-release-trunk-4-1/lastSuccessfulBuild/artifact/cloveretl.server/dist/ using bin/startup.bat it starts the server using java from JRE_HOME. This may be wrong since I have JAVA_HOME set too.

      My JRE_HOME points to regular jre
      My JAVA_HOME points to jdk

      The regular jre doesn't have compiler so this introduces some problems e.g. in checkConfig:

      I have windows7, please test it on linux.

      1. Set JRE_HOME to pure jre (without compiler)
      2. Set JAVA_HOME to jdk
      3. Download and start tomcat bundle using startup.sh
      4. Connect to the server from Designer and open attached graph (compiling.grf) in some server project
      5. See if the checkConfig on the component works or not

        Attachments

          Activity

            People

            Assignee:
            reichmanf Filip Reichman
            Reporter:
            salamonp Pavel Salamon
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: